Starling Cloud Assistant not sending messages.

Incident Report for One Identity Starling

Postmortem

What happened?

08/21/25 6:43 AM UTC

Functionality of Starling Cloud Assistant US/EU was interrupted. 

What went wrong and why?

The client secrets used by the Cloud Assistant application expired.  This caused the Cloud Assistant apps in Prod US and EU to fail authentication thus interrupting functionality.  Automated emails are used to notify our product teams of upcoming secret expiries and to take action.  This email notification was mis-processed by our internal team, so the corresponding work items were not created or performed. 

How did we respond?

The secrets were updated and the Cloud Assistant applications were restarted, resolving issue. 

How are we making incidents like this less likely or less impactful?

Our team is automating the email workflow to create a work item so that secret expiration notices are not missed in future.

Posted Sep 04, 2025 - 13:38 PDT

Resolved

This issue has been resolved, all functionality should be back to normal at this time.
Posted Aug 21, 2025 - 10:33 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 10:13 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 21, 2025 - 09:06 PDT

Investigating

We are investigating issue with Starling Cloud Assistant not sending messages. We will provide regular updates as the investigation/resolution progresses.
Posted Aug 21, 2025 - 08:43 PDT
This incident affected: One Identity Starling EMEA (Cloud Assistant), One Identity Starling NA (Cloud Assistant), and One Identity Starling (Cloud Assistant).