Manage 2FA site down
Incident Report for One Identity Starling
Resolved
This incident has no impact to Starling 2FA customers
Posted Sep 10, 2020 - 10:59 CEST
Investigating
We are currently investigating this issue.
Posted Sep 10, 2020 - 08:08 CEST
This incident affected: One Identity Starling (Two-Factor Authentication).