PAM Essentials RDP sessions down.

Incident Report for One Identity Starling

Postmortem

Service Incident Summary

Product: One Identity Starling PAM Essentials
Region: United States
Date: October 9, 2025

What happened

On October 9, 2025, at 6:05 PM UTC, customers using One Identity Starling PAM Essentials in the US region experienced an interruption to Remote Desktop session connectivity.

Service was fully restored by 9:18 PM UTC.

What caused the issue

The disruption was caused by an outage within Microsoft Azure’s West US data center, triggered by a power-related failure during scheduled maintenance. This event impacted several Azure networking services.

As a result, our service experienced an unusually high volume of network requests, which caused application components to exceed memory limits and temporarily stop responding.

How we resolved the issue

Once the root cause was identified, we scaled the affected application components to handle the increased request volume. This action restored service while Microsoft worked to resolve the underlying data center issue.

What we are doing to prevent future impact

While this type of cloud infrastructure failure is rare, we are taking steps to reduce the impact of similar events in the future by:

  • Continuing to monitor system health and memory utilization in real time
  • Reviewing scaling strategies and resilience options as our infrastructure evolves
  • Applying lessons learned from this incident to ongoing platform improvements
Posted Dec 18, 2025 - 08:03 PST

Resolved

Setting status to resolved, the 3rd party vendor has confirmed the issue has been resolved.
Posted Oct 13, 2025 - 15:22 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 12, 2025 - 21:00 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 12, 2025 - 13:00 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 12, 2025 - 08:19 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 11, 2025 - 22:43 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 11, 2025 - 11:17 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 11, 2025 - 06:59 PDT

Update

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 10, 2025 - 22:32 PDT

Monitoring

We have identified the issue is with a 3rd party vendor experiencing a network related outage. We have taken steps to mitigate the impact on our customers. We will continue to monitor situation and await final resolution from vendor.
Posted Oct 10, 2025 - 14:57 PDT

Update

We are continuing to investigate this issue and will update as we work to identify and resolve the issue.
Posted Oct 10, 2025 - 13:27 PDT

Update

We are continuing to investigate this issue and will update as we work to identify and resolve the issue.
Posted Oct 10, 2025 - 11:58 PDT

Update

We are continuing to investigate this issue and will update as we work to identify and resolve the issue.
Posted Oct 10, 2025 - 10:55 PDT

Investigating

We are currently see issues with RDP session not connecting. We are investigating and will update as we work to identify and resolve the issue.
Posted Oct 10, 2025 - 09:45 PDT
This incident affected: One Identity Starling NA (PAM Essentials).